Проблемка с Antminer S7/S9

Попал мне в руки Antminer S7 с такой проблемой — ASIC запускается и после 1 минуты работы плавно падает хешрейт.

Первое предположение и оно же верное по итогу — умерший куллер.

Antminer ASIC S7

Действительно, в web-интерфейсе один из вентиляторов показывал 0 оборотов, хотя сам вентилятор работал без проблем и посторонних звуков не издавал.

Я предположил, что срабатывает защита майнера от перегрева.

У нас обороты не показывал первый куллер в web интерфейсе — это впускной вентилятор.

Вентилятор Antminer ASIC S7

Снимаем крыльчатку вентилятора как в прошлой статье: https://legnum.info/zapuskaem-bp-hp-aa23530/

И смотрим на контроллер управления вентилятором, он имеет подгоревшую микросхему, что скорее всего и является причиной не работы тахометра.

Тахометр вентилятора DELTA

Под рукой у меня был только вентилятор с меньшими оборотами, до 600. Его установка не дала результата, т.к. видимо лимит оборотов в программе майнера больше. ASIC также работал минуту и после хешрейт падал до 0.

Чуть позже я взял на пробу такой же ASIC, чтобы убедится что проблема в вентиляторе, установил и подключил от него вентиляторы, но начались чудеса, перестал показывать обороты второй куллер, который на выпуске.

Оказалось что слегка подгорел +(красный провод) на разъеме вентилятора и хотя куллер крутится, обороты не показывались.

Контакты были почищены и после этого оба вентилятора стали показывать обороты.

Для опыта я поменял местами контроллеры которые имели разную rev. Так вот на второй контроллер ведет себя при отсутствии сигнала оборотов так же, но только он еще и пищит, сигнализируя о проблеме. Скорее всего вопрос только в прошивке майнера.

Плату контроллера я поставил с другого вентилятора и теперь майнер вернулся на свое рабочее место.